Ansible'ın ücretsiz sürümünü kullanıyorum. Denetleyicim bir CentOS 7 ve ana bilgisayarım bir Win 2008 R2 SP1. Komutu çalıştırdığımda ansible win -m win_pingaşağıdaki hatayı alıyorum:

192.168.1.158 | FAILED! => {
    "changed": false,
    "module_stderr": "\nProcess is terminated due to StackOverflowException.\n",
    "module_stdout": "",
    "msg": "MODULE FAILURE\nSee stdout/stderr for the exact error",
    "rc": 1
}

2008 R2 SP1'imde şunlar var:

  1. .NET 4.5.2 yüklendi

  2. Powershell sürüm 3.0

Denetleyici sunucusunda:

  1. Ansible'ın ücretsiz sürümünü kullanma

  2. Ansible ver 2.11.6

  3. Python 3.6.8

Kontrol sunucumun Win Server 2016'ma erişebildiğini/yönetebildiğini ancak bazı nedenlerden dolayı 2008 R2 SP1'imde sorunlar olduğunu onaylayabilirim.

Powershell belleği ile ilgili olabileceği bir yerde okudum? Bu doğru mu? Herhangi bir yardım takdir edilecektir.

no answer