ฉันมีamazon linux ami ที่เก่ามากซึ่งฉันต้องติดตั้ง certbot สำหรับ nginx ของฉันซึ่งใช้งานเว็บไซต์ php ตอนนี้ฉันต้องติดตั้ง ssl บนเว็บไซต์นี้ แต่ฉันไม่สามารถติดตั้ง certbot-nginx บนเซิร์ฟเวอร์ของฉันได้ ทุกครั้งที่ฉันพยายามติดตั้ง

sudo yum install python2-certbot-nginx.noarch

มันแสดงข้อผิดพลาดในการพึ่งพา จบแบบนี้

--> Processing Dependency: python-requests >= 2.6.0 for package: python2-requests-2.6.0-0.el7.noarch
---> Package python2-six.noarch 0:1.9.0-0.el7 will be installed
--> Processing Dependency: python-six >= 1.9.0 for package: python2-six-1.9.0-0.el7.noarch
---> Package setools-libs.x86_64 0:3.3.7-34.23.amzn1 will be installed
--> Finished Dependency Resolution
Error: Package: python2-requests-2.6.0-0.el7.noarch (epel)
           Requires: python-requests >= 2.6.0
           Installed: python26-requests-1.2.3-5.10.amzn1.noarch (@amzn-main)
               python-requests = 1.2.3-5.10.amzn1
Error: Package: python2-acme-1.11.0-1.el7.noarch (epel)
           Requires: python2-cryptography
Error: Package: python2-acme-1.11.0-1.el7.noarch (epel)
           Requires: pyOpenSSL >= 0.13.1
           Installing: python26-pyOpenSSL-0.10-2.8.amzn1.x86_64 (amzn-main)
               pyOpenSSL = 0.10-2.8.amzn1
Error: Package: python2-acme-1.11.0-1.el7.noarch (epel)
           Requires: python2-pyasn1
Error: Package: certbot-1.11.0-1.el7.noarch (epel)
           Requires: systemd
Error: Package: python2-six-1.9.0-0.el7.noarch (epel)
           Requires: python-six >= 1.9.0
           Installed: python26-six-1.8.0-1.23.amzn1.noarch (@amzn-main)
               python-six = 1.8.0-1.23.amzn1
Error: Package: python2-josepy-1.3.0-2.el7.noarch (epel)
           Requires: python2-setuptools
Error: Package: python2-josepy-1.3.0-2.el7.noarch (epel)
           Requires: python2-cryptography
Error: Package: python2-certbot-1.11.0-1.el7.noarch (epel)
           Requires: python2-cryptography >= 1.2.3
Error: Package: python2-acme-1.11.0-1.el7.noarch (epel)
           Requires: pyOpenSSL >= 0.13.1
           Available: python26-pyOpenSSL-0.10-2.8.amzn1.x86_64 (amzn-main)
               pyOpenSSL = 0.10-2.8.amzn1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

ฉันได้ลองติดตั้ง yum-utils แล้วpackage-cleanup --leavesแต่ก็ยังมีข้อผิดพลาดต่อไปนี้ปรากฏขึ้น ใครช่วยบอกวิธีป้องกันปัญหานี้ได้บ้าง ขอบใจ. btw เซิร์ฟเวอร์ของฉัน os-release

NAME="Amazon Linux AMI"
VERSION="2018.03"
ID="amzn"
ID_LIKE="rhel fedora"
VERSION_ID="2018.03"
PRETTY_NAME="Amazon Linux AMI 2018.03"
ANSI_COLOR="0;33"
CPE_NAME="cpe:/o:amazon:linux:2018.03:ga"
HOME_URL="http://aws.amazon.com/amazon-linux-ami/"

ใครสามารถช่วยฉันด้วยสิ่งนี้? ฉันคิดว่าถ้าฉันสามารถลบปัญหาการพึ่งพาเหล่านี้ทั้งหมดได้ มากกว่าที่ฉันสามารถติดตั้ง python2-certbot-nginx และฉันจะทำ ssl ได้ ฉันจะได้รับความช่วยเหลือใด ๆ ขอบคุณล่วงหน้า.

answer

ฉันยังประสบปัญหาที่คล้ายกันเมื่อสองสามเดือนก่อนใน Amazon linux แก้ไขโดยการติดตั้ง certbot ผ่าน pip คำสั่งที่ฉันใช้:

pip install virtualenv
virtualenv ~/.certbot
source ~/.certbot/bin/activate
pip install 'setuptools<41'
pip install certbot
pip install 'parsedatetime<2.6'

ตอนนี้เพียงแค่สร้างใบรับรองโดยออกคำสั่งด้านล่าง

sudo ~/.certbot/bin/certbot certonly --webroot -w /usr/share/nginx/html/example -d example.com