Ik heb twee sets Linux-VM's in een GCP-omgeving (Google cloud): Debian9 en RHEL8. De RHEL8-omgeving is FIPS-140 ingeschakeld vanwege beveiligings-/compliancevereisten. Geen van onze Ansible-playbooks werkt met de FIPS-compatibele RHEL-VM's, maar werkt nog steeds prima op de Debian-VM's. De Linux-besturingshost is ook Debian9.

Voor de mislukte RHEL8-playbooks, zie je dit logboek in de Ansible playbook -vvvv-uitvoer:

ValueError: [digital envelope routines: EVP_DigestInit_ex] disabled for FIPS

Waar kan ik naar kijken om deze Playbooks te laten werken met RHEL8/FIPS VM's?

no answer