शीर्षक यह सब कहता है। मुझे क्लाउड रन पर 32-बिट बाइनरी चलाने का एक तरीका चाहिए, जो केवल 64-बिट का समर्थन करता है

मैं जो खोज रहा हूं वह किसी प्रकार का एमुलेटर या संगतता परत है जिसे मैं स्थापित कर सकता हूं।

मैं प्रोग्राम को 64-बिट्स में संकलित नहीं कर सकता।

answer

मुझे वह प्रोग्राम मिला जिसकी मुझे तलाश थी, जो कि qemu है

आप जोड़ने के बाद apt install -y qemu-userअपने Dockerfile करने के लिए आप कमांड के साथ एक 32-बिट द्विआधारी चला सकते हैं qemu-i386 ./file🎉

मुझे आशा है कि एक दिन कोई इस प्रश्न और उत्तर को देखेगा और इसे उपयोगी पाएगा।

नया योगदानकर्ता
kess is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.