Je n'ai que deux sites IIS :

  • sous-domaine.domaine1.com
  • sous-domaine.domaine2.com

Et deux certificats :

  • sous-domaine.domain1.com une norme
  • *.domain2.com un caractère générique

Pour une raison étrange, le site avec le caractère générique semble correctement configuré à la fois dans la console et dans netsh http show sslcert, mais lorsque j'accède au site sur n'importe quel navigateur, il échoue avec l'erreur NET::ERR_CERT_COMMON_NAME_INVALID. Lorsque je vérifie le certificat, il indique subdomain.domain1.com. L'autre site (subdomain.domain1.com) fonctionne parfaitement et a été créé en premier.

résultat de netsh http show sslcert:

SSL Certificate bindings:
----------------------------

    IP:Port                      : subdomain.domain1.com:443
    Certificate Hash             : e36cffe0f7a817ca39dca65955a194d83671dd67
    Application ID               : {4dc3e181-e14b-4a21-b022-59fc669b0914}
    Certificate Store Name       : My
    Verify Client Certificate Revocation : Enabled
    Verify Revocation Using Cached Client Certificate Only : Disabled
    Usage Check                  : Enabled
    Revocation Freshness Time    : 0
    URL Retrieval Timeout        : 0
    Ctl Identifier               : (null)
    Ctl Store Name               : (null)
    DS Mapper Usage              : Disabled
    Negotiate Client Certificate : Disabled
    Reject Connections           : Disabled
    Disable HTTP2                : Not Set
    Disable QUIC                 : Not Set
    Disable TLS1.2               : Not Set
    Disable TLS1.3               : Not Set
    Disable OCSP Stapling        : Not Set
    Disable Legacy TLS Versions  : Not Set

    IP:Port                      : subdomain.domain2.com:443
    Certificate Hash             : 7c681697ebed1bd653bb08bcbec5cb719795eb64
    Application ID               : {4dc3e181-e14b-4a21-b022-59fc669b0914}
    Certificate Store Name :     : My
    Verify Client Certificate Revocation : Enabled
    Verify Revocation Using Cached Client Certificate Only : Disabled
    Usage Check                  : Enabled
    Revocation Freshness Time    : 0
    URL Retrieval Timeout        : 0
    Ctl Identifier               : (null)
    Ctl Store Name               : (null)
    DS Mapper Usage              : Disabled
    Negotiate Client Certificate : Disabled
    Reject Connections           : Disabled
    Disable HTTP2                : Not Set
    Disable QUIC                 : Not Set
    Disable TLS1.2               : Not Set
    Disable TLS1.3               : Not Set
    Disable OCSP Stapling        : Not Set
    Disable Legacy TLS Versions  : Not Set

Je n'ai aucune idée de pourquoi cela s'est produit, la case à cocher SNI est cochée. J'ai essayé, sans succès de :

  • suppression, la liaison et recréez-la via PowerShell.
  • iisreset
  • redémarrage du serveur

Un indice ? THX

no answer