• Servidor Ubuntu 20.04 (sin GUI) como host

  • varios invitados funcionando perfectamente, cada uno con su propio LV

  • Creé un LV para una VM llamada "prueba", similar a los invitados que trabajan

  • Particionó el LV: una partición de arranque ext4, un intercambio

  • sistema raíz rsync-d en la partición de arranque.

  • creó una nueva VM usando virt-install así:

    virt-install --name=test
    --memory 2000
    --vcpus 2
    --disk path=/dev/vg-main/test,bus=virtio,cache=none,format=raw
    --network="bridge=br0, model=virtio"
    --graphics vnc,port=5905
    --noautoconsole
    --import
    --os-type=generic

Cuando inicio la máquina virtual, se cuelga de la siguiente manera:

SeaBIOS (version 1.13.0-1ubuntu1.1)
Machine UUID <uuid of xml file>
iPXE (http://ipxe.org) 00:03.0 CA00 PCI2.10 PnP+7CF8C880+7CECC880 CA00

Booting from Hard Disk...

El sistema de archivos es montable y completo:

[email protected]:~/test# losetup /dev/loop7 /dev/vg-main/test
[email protected]:~/test# kpartx -av /dev/loop7
add map loop7p1 (253:11): 0 95614977 linear 7:7 3999744
add map loop7p2 (253:12): 0 5238784 linear 7:7 99616768
[email protected]:~/test# mount /dev/mapper/loop7p1 /mnt
[email protected]:~/test# ls /mnt
backup  build  etc   initrd          lib         mnt   root  srv  usr      vmlinuz.old
bin     cdrom  from  initrd.img      lost+found  opt   run   sys  var
boot    dev    home  initrd.img.old  media       proc  sbin  tmp  vmlinuz

y la salida de fdisk /dev/vg-main/test se ve así:

Disk /dev/vg-main/test: 50 GiB, 53687091200 bytes, 104857600 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 02EA0DD2-3166-495C-9E0F-37DDEFD15786

Device                Start       End  Sectors  Size Type
/dev/vg-main/test1  3999744  99614720 95614977 45.6G Linux filesystem
/dev/vg-main/test2 99616768 104855551  5238784  2.5G Linux swap

He comparado el archivo .xml con otros archivos .xml en funcionamiento y no veo nada obvio.

<disk type='block' device='disk'>
  <driver name='qemu' type='raw' cache='none' io='native'/>
  <source dev='/dev/vg-main/test'/>
  <target dev='vda' bus='virtio'/>
  <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
</disk>

No puedo ver ningún mensaje de error en los registros. Creo que debo haber perdido un paso importante... cualquier ayuda es muy apreciada.

no answer